Planned maintenance on Wednesday, 2021-01-20, 17:00-18:00. Expect some interruptions during that time

Commit 28c401e4 authored by ankit kariryaa's avatar ankit kariryaa

Add parserId and versionInfo in parserInfo

parent 3aed5d4a
package eu.nomad_lab.parsers
import eu.{nomad_lab=>lab}
import eu.nomad_lab.DefaultPythonInterpreter
import org.{json4s => jn}
import scala.collection.breakOut
object DlPolyParser extends SimpleExternalParserGenerator(
name = "DlPolyParser",
parserInfo = jn.JObject(
("name" -> jn.JString("DlPolyParser")) ::
("version" -> jn.JString("1.0")) :: Nil),
("parserId" -> jn.JString("DlPolyParser" + lab.DlPolyVersionInfo.version)) ::
("versionInfo" -> jn.JObject(
("nomadCoreVersion" -> jn.JString(lab.NomadCoreVersionInfo.version)) ::
(lab.DlPolyVersionInfo.toMap.map{ case (key, value) =>
(key -> jn.JString(value.toString))
}(breakOut): List[(String, jn.JString)])
)) :: Nil
),
mainFileTypes = Seq("text/.*"),
mainFileRe = """ DL_POLY """.r,
cmd = Seq(DefaultPythonInterpreter.python2Exe(), "${envDir}/parsers/dl_poly/parser/parser-dl_poly/SimpleDL_POLYParser.py",
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment