rename IDX_X etc to IDXC_X etc

I think it's more obvious when we talk about "index of component" and
"index of variable" what is meant, rather than having "FIELD_IDX" and
plain "IDX".
1 job for feature/ellipsoids