Planned maintenance on Wednesday, 2021-01-20, 17:00-18:00. Expect some interruptions during that time

Commit 65c76051 authored by Simon May's avatar Simon May

Update gcc/intel and impi compiler module conflict

parent 8d89a260
......@@ -6,15 +6,18 @@
# hierarchical module system: compiler → mpi → libraries
# Modules fftw-mpi and hdf5-mpi become available after loading a compiler module
# and an MPI library (impi). The available modules are determined by the
# compiler/MPI combination that was loaded *last* (i.e. in this case, fftw-mpi is
# the version compiled with intel and impi).
# compiler/MPI combination that was loaded (i.e. in this case, fftw-mpi is the
# version compiled with intel and impi).
# Currently, loading both compiler modules (gcc and intel) causes problems with the
# MODULEPATH that is set up by impi, so make sure to load another compiler only
# *after* impi is loaded!
module load intel
module load impi
module load fftw-mpi
module load hdf5-serial
module load gsl
module load pkg-config
#module load gcc # currently not a good idea to load both intel and gcc
module load gcc # load *after* intel and impi!
module load clang
module load datashare
module load git
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment