Fixed handling for nperiodic_dimensions = 0. #461

14 jobs for fastapi in 25 minutes and 37 seconds
Status Name Job ID Coverage
  Build
passed build #1244628

00:11:19

 
  Test
failed dev setup tests #1244643

00:03:55

passed gui linting #1244630

00:03:01

passed gui tests #1244632

00:02:52

failed install tests #1244645

00:01:26

passed python linting #1244629

00:06:38

passed python tests #1244631

00:14:18

76.0%
failed dev setup tests #1244634

00:04:15

failed install tests #1244644

00:00:26

failed install tests #1244633

00:01:43

 
  Release
skipped deploy dev #1244635
allowed to fail manual
skipped deploy prod beta #1244636
allowed to fail manual
skipped python package #1244638
allowed to fail manual
skipped release latest image #1244637
allowed to fail manual
 
Name Stage Failure
failed
install tests Test
  Downloading jmespath-0.10.0-py2.py3-none-any.whl (24 kB)
Collecting jsonref
Downloading jsonref-0.2-py3-none-any.whl (9.3 kB)
Collecting matplotlib
Downloading matplotlib-3.3.3-cp37-cp37m-manylinux1_x86_64.whl (11.6 MB)
Collecting cycler>=0.10
ERROR: HTTP error 502 while getting https://files.pythonhosted.org/packages/f7/d2/e07d3ebb2bd7af696440ce7e754c59dd546ffe1bbe732c8ab68b9c834e61/cycler-0.10.0-py2.py3-none-any.whl#sha256=1d8a5ae1ff6c5cf9b93e8811e581232ad8920aeec647c37316ceac982b08cb2d (from https://pypi.org/simple/cycler/)
ERROR: Could not install requirement cycler>=0.10 from https://files.pythonhosted.org/packages/f7/d2/e07d3ebb2bd7af696440ce7e754c59dd546ffe1bbe732c8ab68b9c834e61/cycler-0.10.0-py2.py3-none-any.whl#sha256=1d8a5ae1ff6c5cf9b93e8811e581232ad8920aeec647c37316ceac982b08cb2d (from matplotlib->ase==3.19.0->nomad-lab==0.10.0) because of HTTP error 502 Server Error: Gateway Error for url: https://files.pythonhosted.org/packages/f7/d2/e07d3ebb2bd7af696440ce7e754c59dd546ffe1bbe732c8ab68b9c834e61/cycler-0.10.0-py2.py3-none-any.whl for URL https://files.pythonhosted.org/packages/f7/d2/e07d3ebb2bd7af696440ce7e754c59dd546ffe1bbe732c8ab68b9c834e61/cycler-0.10.0-py2.py3-none-any.whl#sha256=1d8a5ae1ff6c5cf9b93e8811e581232ad8920aeec647c37316ceac982b08cb2d (from https://pypi.org/simple/cycler/)
ERROR: Job failed: exit code 1
failed
dev setup tests Test
Requirement already satisfied: typing-extensions>=3.6.4 in /usr/local/lib/python3.7/site-packages (from importlib-metadata->Pint->nomadcore->octopusparser==0.1) (3.7.4.3)
Requirement already satisfied: zipp>=0.5 in /usr/local/lib/python3.7/site-packages (from importlib-metadata->Pint->nomadcore->octopusparser==0.1) (3.4.0)
Installing collected packages: octopusparser
Running setup.py develop for octopusparser
Successfully installed octopusparser
dependencies/parsers/phonopy
ERROR: Could not find a version that satisfies the requirement phonopy
ERROR: No matching distribution found for phonopy
ERROR: Job failed: exit code 1