Commit f5913571 authored by Luigi Sbailo's avatar Luigi Sbailo
Browse files

Packages update - numpy, pandas, scikit learn

parent a92b0048
......@@ -47,6 +47,7 @@ USER $NB_UID
# to the first line here (e.g., nglview, jupyter_contrib_nbextensions, etc.)
# https://github.com/ipython-contrib/jupyter_contrib_nbextensions
RUN conda install conda=4.11
RUN pip install --upgrade pip
RUN conda install --quiet --yes \
'pytorch::pytorch-cpu==1.1.0' \
......@@ -62,7 +63,11 @@ RUN conda install --quiet --yes \
'orjson' \
'hdbscan' \
'pyyaml==6' \
'pynndescent' \
'numba==0.52' \
'scikit-learn==0.24' \
'pandas==1.2.5'\
'urllib3==1.26.5'\
'nest-asyncio '\
&& conda install -c plotly plotly-orca \
&& conda install -c conda-forge umap-learn \
&& conda clean -tipsy \
......@@ -74,6 +79,8 @@ RUN conda install --quiet --yes \
&& jupyter nbextension enable collapsible_headings/main \
&& fix-permissions $CONDA_DIR \
&& fix-permissions /home/$NB_USER
RUN pip install nomad-lab --extra-index-url https://gitlab.mpcdf.mpg.de/api/v4/projects/2187/packages/pypi/simple
# Dependecies:
......@@ -212,10 +219,6 @@ RUN pip install ./analytics-soap-atomic-charges
RUN pip install ./analytics-tcmi
RUN pip install ./analytics-tetradymite-PRM2020
RUN pip install nomad-lab
# Temporary fix numpy version
RUN pip install numpy==1.17
USER root
# Trick to stop caching
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment