Commit fcc82a10 authored by ultimanet's avatar ultimanet
Browse files

Merge remote-tracking branch 'upstream/master' into mpi

parents 9177bbf0 6560632f
...@@ -101,7 +101,7 @@ Requirements ...@@ -101,7 +101,7 @@ Requirements
Download Download
........ ........
The latest release is tagged **v1.0.6** and is available as a source package The latest release is tagged **v1.0.7** and is available as a source package
at `<https://github.com/information-field-theory/nifty/tags>`_. The current at `<https://github.com/information-field-theory/nifty/tags>`_. The current
version can be obtained by cloning the repository:: version can be obtained by cloning the repository::
......
...@@ -30,7 +30,7 @@ try: ...@@ -30,7 +30,7 @@ try:
except(ImportError): except(ImportError):
try: try:
import healpy as hp import healpy as hp
if lv(hp.__version__) <= lv('1.8.1'): if lv(hp.__version__) < lv('1.8.1'):
raise ImportError(about._errors.cprint("ERROR: installed healpy version is older than 1.8.1!")) raise ImportError(about._errors.cprint("ERROR: installed healpy version is older than 1.8.1!"))
except(ImportError): except(ImportError):
about.infos.cprint("INFO: neither libsharp_wrapper_gl nor healpy available.") about.infos.cprint("INFO: neither libsharp_wrapper_gl nor healpy available.")
...@@ -41,7 +41,7 @@ except(ImportError): ...@@ -41,7 +41,7 @@ except(ImportError):
else: else:
try: try:
import healpy as hp import healpy as hp
if lv(hp.__version__) <= lv('1.8.1'): if lv(hp.__version__) < lv('1.8.1'):
raise ImportError(about._errors.cprint("ERROR: installed healpy version is older than 1.8.1!")) raise ImportError(about._errors.cprint("ERROR: installed healpy version is older than 1.8.1!"))
except(ImportError): except(ImportError):
from nifty_lm import lm_space,gl_space ## import lm & gl from nifty_lm import lm_space,gl_space ## import lm & gl
......
...@@ -150,7 +150,7 @@ from multiprocessing import Value as mv ...@@ -150,7 +150,7 @@ from multiprocessing import Value as mv
from multiprocessing import Array as ma from multiprocessing import Array as ma
from nifty_mpi_data import distributed_data_object from nifty_mpi_data import distributed_data_object
__version__ = "1.0.6" __version__ = "1.0.7"
pi = 3.1415926535897932384626433832795028841971693993751058209749445923078164062862089986280348253421170679 pi = 3.1415926535897932384626433832795028841971693993751058209749445923078164062862089986280348253421170679
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment