Commit b116c7ed authored by Martin Reinecke's avatar Martin Reinecke

Merge branch 'matplotlib_backend' into 'NIFTy_5'

Set matplotlib backend in Dockerfile

See merge request ift/nifty-dev!64
parents e7ff7772 c14a52f6
......@@ -65,7 +65,6 @@ pages:
- NIFTy_4
before_script:
- export MPLBACKEND="agg"
- python setup.py install --user -f
- python3 setup.py install --user -f
......
......@@ -29,6 +29,9 @@ RUN apt-get update && apt-get install -y python-matplotlib python3-matplotlib \
&& python3 -m pip install --upgrade pip && python3 -m pip install jupyter && python -m pip install --upgrade pip && python -m pip install jupyter \
&& rm -rf /var/lib/apt/lists/*
# Set matplotlib backend
ENV MPLBACKEND agg
# Create user (openmpi does not like to be run as root)
RUN useradd -ms /bin/bash testinguser
USER testinguser
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment