Commit 5cc408cd authored by Mihai Baltac's avatar Mihai Baltac

for some reason Nifty is built with python2 but better_apidoc.py is executed...

for some reason Nifty is built with python2 but better_apidoc.py is executed with python 3 in the CI; therefore it does not find the nifty library to generate it's documentation; so now testing run with python2 on both sides
parent b6a38184
Pipeline #24913 passed with stages
in 4 minutes and 7 seconds
......@@ -12,7 +12,7 @@ before_script:
- sh ci/install_basics.sh
- pip install --process-dependency-links -r ci/requirements.txt
- pip3 install --process-dependency-links -r ci/requirements.txt
- python setup.py install
- python2 setup.py install
# test_min:
......@@ -30,7 +30,7 @@ before_script:
pages:
script:
- python docs/better_apidoc.py -l -e -d 2 -t docs/generation-templates -o docs/source/mod nifty4
- python2 docs/better_apidoc.py -l -e -d 2 -t docs/generation-templates -o docs/source/mod nifty4
- sphinx-build -b html docs/source/ docs/build/
- mv docs/build/ public/
artifacts:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment