Commit 72d28359 authored by Andreas Marek's avatar Andreas Marek

Prepare releas of ELPA 2017.05.003

parent 8df5f71e
Changelog for ELPA 2017.05.003
- remove bug in invert_triangular, which had been introduced
in ELPA 2017.05.002
Changelog for ELPA 2017.05.002
Mainly bugfixes for ELPA 2017.05.001:
......
......@@ -2,7 +2,7 @@
## Preamle ##
This file provides documentation on how to build the *ELPA* library in **version ELPA-2017.05.002**.
This file provides documentation on how to build the *ELPA* library in **version ELPA-2017.05.003**.
With release of **version ELPA-2017.05.001** the build process has been significantly simplified,
which makes it easier to install the *ELPA* library
......
......@@ -2,7 +2,7 @@
## Current Release ##
The current release is ELPA 2017.05.002. The current supported API version
The current release is ELPA 2017.05.003. The current supported API version
is 20170403. This release supports the earliest API version 20170403.
## About *ELPA*
......
This file contains the release notes for the ELPA 2017.05.002 version
This file contains the release notes for the ELPA 2017.05.003 version
What is new?
-------------
For detailed information about changes since release ELPA 2016.11.001 please have a look at the Changelog file
Highlights are:
For detailed information about changes since release ELPA 2017.05.002 please have a look at the Changelog file
- a more generic and more flexible API, which allows easy implementation of upcoming features
- faster GPU implementation, especially for ELPA 1stage
- the restriction of the block-cyclic distribution blocksize = 128 in the GPU
case is relaxed
- Faster CPU implementation due to better blocking
- support of already banded matrices (new API only!)
- improved KNL support
- This release contains a fix for a bug introduced in ELPA 2017.05.002
ABI change
---------------------
Since release 2016.05.001 the ABI has not changed. Only additional interfaces habe been added, please have also a look
at the DEPRECTATED_FEATURES file
Since release 2017.05.001 the ABI has not changed.
Any incompatibilities to previous version?
---------------------------------------
As mentioned before, the ABI of ELPA was not changed; There is no
incompatibility with the previous version ELPA 2016.11.001.
incompatibility with the previous version ELPA 2017.05.002.
......@@ -151,7 +151,7 @@ Local documentation (via man pages) should be available (if *ELPA* has been inst
For example "man elpa2_print_kernels" should provide the documentation for the *ELPA* program which prints all
the available kernels.
Also a [online doxygen documentation] (http://elpa.mpcdf.mpg.de/html/Documentation/ELPA-2017.05.002/html/index.html)
Also a [online doxygen documentation] (http://elpa.mpcdf.mpg.de/html/Documentation/ELPA-2017.05.003/html/index.html)
for each *ELPA* release is available.
......@@ -9,7 +9,7 @@ Local documentation (via man pages) should be available (if *ELPA* has been inst
For example "man elpa2_print_kernels" should provide the documentation for the *ELPA* program which prints all
the available kernels.
Also a [online doxygen documentation] (http://elpa.mpcdf.mpg.de/html/Documentation/ELPA-2017.05.002/html/index.html)
Also a [online doxygen documentation] (http://elpa.mpcdf.mpg.de/html/Documentation/ELPA-2017.05.003/html/index.html)
for each *ELPA* release is available.
......
......@@ -27,7 +27,7 @@ AM_SILENT_RULES([yes])
# by the current interface, as they are ABI compatible (e.g. only new symbols
# were added by the new interface)
#
AC_SUBST([ELPA_SO_VERSION], [10:0:2])
AC_SUBST([ELPA_SO_VERSION], [10:1:2])
# API Version
AC_DEFINE([EARLIEST_API_VERSION], [20170403], [Earliest supported ELPA API version])
......@@ -1035,7 +1035,7 @@ m4_foreach_w([elpa_m4_kind],[real complex],[
#echo " "
#echo "***********************************************************************"
#echo "* This is a the release of ELPA 2017.05.002 *"
#echo "* This is a the release of ELPA 2017.05.003 *"
#echo "* It mainly contains bugfixes to ELPA 2017.05.001 *"
#echo "***********************************************************************"
#echo " "
......
......@@ -32,7 +32,7 @@
%endif
Name: elpa
Version: 2017.05.002
Version: 2017.05.003
Release: 1
Summary: A massively parallel eigenvector solver
License: LGPL-3.0
......
AC_PREREQ([2.69])
AC_INIT([elpa_test_project],[2017.05.002], elpa-library@rzg.mpg.de)
elpaversion="2017.05.002"
AC_INIT([elpa_test_project],[2017.05.003], elpa-library@rzg.mpg.de)
elpaversion="2017.05.003"
AC_CONFIG_SRCDIR([src/test_real.F90])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
AC_PREREQ([2.69])
AC_INIT([elpa_test_project],[2017.05.002], elpa-library@rzg.mpg.de)
elpaversion="2017.05.002"
AC_INIT([elpa_test_project],[2017.05.003], elpa-library@rzg.mpg.de)
elpaversion="2017.05.003"
AC_CONFIG_SRCDIR([src/test_real2.F90])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
AC_PREREQ([2.69])
AC_INIT([elpa2_test_project],[2017.05.002], elpa-library@rzg.mpg.de)
elpaversion="2017.05.002"
AC_INIT([elpa2_test_project],[2017.05.003], elpa-library@rzg.mpg.de)
elpaversion="2017.05.003"
AC_CONFIG_SRCDIR([src/test_real2.F90])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
AC_PREREQ([2.69])
AC_INIT([elpa_test_project],[2017.05.002], elpa-library@rzg.mpg.de)
elpaversion="2017.05.002"
AC_INIT([elpa_test_project],[2017.05.003], elpa-library@rzg.mpg.de)
elpaversion="2017.05.003"
AC_CONFIG_SRCDIR([src/test_real.F90])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment