Commit 2a237dfe authored by Andreas Marek's avatar Andreas Marek

Prepare release of ELPA 2017.11.001.rc1

parent 899bd7bf
Changelog for ELPA 2017.11.001.rc1
- added new compute kernels for IBM Power8 and Fujistu Sparc64
processors
- a first implementation of autotuning capability
Changelog for ELPA 2017.05.003
- remove bug in invert_triangular, which had been introduced
......
......@@ -18,11 +18,11 @@ In order to unfiy the namespace of the *ELPA* public interfaces, several interfa
have been replaced by new names. The old interfaces will be removed
Deprecated interface Replacement Comment
================================================================================
get_elpa_row_col_coms elpa_get_communicators (removed)
get_elpa_communicators elpa_get_communicators (removed)
solve_evp_real elpa_solve_evp_real_1stage_double (removed)
solve_evp_complex elpa_solve_evp_complex_1stage_double (removed)
==================================================================================================
get_elpa_row_col_coms elpa_get_communicators (removed since 2017.11.001)
get_elpa_communicators elpa_get_communicators (removed since 2017.11.001)
solve_evp_real elpa_solve_evp_real_1stage_double (removed since 2017.11.001)
solve_evp_complex elpa_solve_evp_complex_1stage_double (removed since 2017.11.001)
solve_evp_real_1stage elpa_solve_evp_real_1stage_double
solve_evp_complex_1stage elpa_solve_evp_complex_1stage_double
solve_evp_real_2stage elpa_solve_evp_real_2stage_double
......
# Installation guide for the *ELPA* library#
## Preamle ##
## Preamble ##
This file provides documentation on how to build the *ELPA* library in **version ELPA-2017.05.003**.
This file provides documentation on how to build the *ELPA* library in **version ELPA-2017.11.001.rc1**.
With release of **version ELPA-2017.05.001** the build process has been significantly simplified,
which makes it easier to install the *ELPA* library
......
......@@ -3,6 +3,12 @@
For more details and recent updates please visit the online [issue system] (https://gitlab.mpcdf.mpg.de/elpa/elpa/issues)
Issues which are not mentioned in a newer release are (considered as) solved
### ELPA 2017.11.001.rc1 release ###
- the elpa autotune print functions cannot print at the moment
### ELPA 2017.05.003 release ###
- at the moment no issues are known
### ELPA 2017.05.002 release ###
- at the moment no issues are known
......
......@@ -73,3 +73,9 @@ https://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
NO incompatible API changes w.r.t. to the previous version. Only some functions have
been added. The state of release 2017.05.001 defines this interface
- 11
Incompatible API changes w.r.t. to the previous version (only in the so called
"legacy interface", since as anounced some deprecated function aliases have been
removed). For the current interface all changes since 2017.05.001 are
compatible, since only some functions have been added.
The state of release 2017.11.001.rc1 defines this interface
......@@ -2,8 +2,8 @@
## Current Release ##
The current release is ELPA 2017.05.003. The current supported API version
is 20170403. This release supports the earliest API version 20170403.
The current release is ELPA 2017.11.001.rc1. The current supported API version
is 20171201. This release supports the earliest API version 20170403.
## About *ELPA*
......
This file contains the release notes for the ELPA 2017.05.003 version
This file contains the release notes for the ELPA 2017.11.001.rc1 version
What is new?
-------------
For detailed information about changes since release ELPA 2017.05.002 please have a look at the Changelog file
For detailed information about changes since release ELPA 2017.05.03 please have a look at the Changelog file
- This release contains a fix for a bug introduced in ELPA 2017.05.002
- This release contains new compute kernels for IBM Power 8 and Fujistu Sparc64 processors
- A first version of autotuning has been implemented
ABI change
---------------------
Since release 2017.05.001 the ABI has not changed.
Since release 2017.05.003 the ABI has changed.
Any incompatibilities to previous version?
---------------------------------------
As mentioned before, the ABI of ELPA was not changed; There is no
incompatibility with the previous version ELPA 2017.05.002.
As mentioned before, the ABI of ELPA was changed;
This change only affectes the old "lecgacy interface", since as
anounced some deprecated function aliases have been removed.
For the current interface there is no incompatibility with the
previous version ELPA 2017.05.003.
......@@ -149,7 +149,7 @@ Local documentation (via man pages) should be available (if *ELPA* has been inst
For example "man elpa2_print_kernels" should provide the documentation for the *ELPA* program which prints all
the available kernels.
Also a [online doxygen documentation] (http://elpa.mpcdf.mpg.de/html/Documentation/ELPA-2017.05.003/html/index.html)
Also a [online doxygen documentation] (http://elpa.mpcdf.mpg.de/html/Documentation/ELPA-2017.11.001.rc1/html/index.html)
for each *ELPA* release is available.
......@@ -9,7 +9,7 @@ Local documentation (via man pages) should be available (if *ELPA* has been inst
For example "man elpa2_print_kernels" should provide the documentation for the *ELPA* program which prints all
the available kernels.
Also a [online doxygen documentation] (http://elpa.mpcdf.mpg.de/html/Documentation/ELPA-2017.05.003/html/index.html)
Also a [online doxygen documentation] (http://elpa.mpcdf.mpg.de/html/Documentation/ELPA-2017.11.001.rc1/html/index.html)
for each *ELPA* release is available.
......
......@@ -27,11 +27,11 @@ AM_SILENT_RULES([yes])
# by the current interface, as they are ABI compatible (e.g. only new symbols
# were added by the new interface)
#
AC_SUBST([ELPA_SO_VERSION], [10:1:2])
AC_SUBST([ELPA_SO_VERSION], [11:0:0])
# API Version
AC_DEFINE([EARLIEST_API_VERSION], [20170403], [Earliest supported ELPA API version])
AC_DEFINE([CURRENT_API_VERSION], [20170403], [Current ELPA API version])
AC_DEFINE([CURRENT_API_VERSION], [20171201], [Current ELPA API version])
AX_CHECK_GNU_MAKE()
......@@ -1138,12 +1138,13 @@ m4_foreach_w([elpa_m4_kind],[real complex],[
])
])
#echo " "
#echo "***********************************************************************"
#echo "* This is a the release of ELPA 2017.05.003 *"
#echo "* It mainly contains bugfixes to ELPA 2017.05.001 *"
#echo "***********************************************************************"
#echo " "
echo " "
echo "***********************************************************************"
echo "* This is a the first release candidate of ELPA 2017.11.001 *"
echo "* There might be still some changes until the final release of *"
echo "* ELPA 2017.11.001 *"
echo "***********************************************************************"
echo " "
if test x"$enable_kcomputer" = x"yes" ; then
echo " "
......
......@@ -32,7 +32,7 @@
%endif
Name: elpa
Version: 2017.05.003
Version: 2017.11.001.rc1
Release: 1
Summary: A massively parallel eigenvector solver
License: LGPL-3.0
......
AC_PREREQ([2.69])
AC_INIT([elpa_test_project],[2017.05.003], elpa-library@rzg.mpg.de)
elpaversion="2017.05.003"
AC_INIT([elpa_test_project],[2017.11.001.rc1], elpa-library@rzg.mpg.de)
elpaversion="2017.11.001.rc1"
AC_CONFIG_SRCDIR([src/test_real.F90])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
AC_PREREQ([2.69])
AC_INIT([elpa_test_project],[2017.05.003], elpa-library@rzg.mpg.de)
elpaversion="2017.05.003"
AC_INIT([elpa_test_project],[2017.11.001.rc1], elpa-library@rzg.mpg.de)
elpaversion="2017.11.001.rc1"
AC_CONFIG_SRCDIR([src/test_real.F90])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
AC_PREREQ([2.69])
AC_INIT([elpa_test_project],[2017.05.003], elpa-library@rzg.mpg.de)
elpaversion="2017.05.003"
AC_INIT([elpa_test_project],[2017.11.001.rc1], elpa-library@rzg.mpg.de)
elpaversion="2017.11.001.rc1"
AC_CONFIG_SRCDIR([src/test_real2.F90])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
AC_PREREQ([2.69])
AC_INIT([elpa2_test_project],[2017.05.003], elpa-library@rzg.mpg.de)
elpaversion="2017.05.003"
AC_INIT([elpa2_test_project],[2017.11.001.rc1], elpa-library@rzg.mpg.de)
elpaversion="2017.11.001.rc1"
AC_CONFIG_SRCDIR([src/test_real2.F90])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment