Commit dd6487a0 authored by Andreas Marek's avatar Andreas Marek
Browse files

ELPA 2021.05.001.rc1

parent d2340043
......@@ -2,8 +2,8 @@
## Current Release ##
The current release is ELPA 2020.11.001 The current supported API version
is 20200417. This release supports the earliest API version 20170403.
The current release is ELPA 2021.05.001.rc1 The current supported API version
is 20210430. This release supports the earliest API version 20170403.
The release ELPA 2018.11.001 was the last release, where the legacy API has been
enabled by default (and can be disabled at build time).
......@@ -130,7 +130,7 @@ the possible configure options.
## Using *ELPA*
Please have a look at the [USERS_GUIDE](USERS_GUIDE.md) file, to get a documentation or at the [online](http://elpa.mpcdf.mpg.de/html/Documentation/ELPA-2020.11.001/html/index.html) doxygen documentation, where you find the definition of the interfaces. You might want to have a look at the [PERFORMANCE tuning document](./documentation/PERFORMANCE_TUNING.md) to avoid some usual pitfalls.
Please have a look at the [USERS_GUIDE](USERS_GUIDE.md) file, to get a documentation or at the [online](http://elpa.mpcdf.mpg.de/html/Documentation/ELPA-2021.05.001.rc1/html/index.html) doxygen documentation, where you find the definition of the interfaces. You might want to have a look at the [PERFORMANCE tuning document](./documentation/PERFORMANCE_TUNING.md) to avoid some usual pitfalls.
## Contributing to *ELPA*
......
......@@ -26,7 +26,7 @@ AM_SILENT_RULES([yes])
# by the current interface, as they are ABI compatible (e.g. only new symbols
# were added by the new interface)
#
AC_SUBST([ELPA_SO_VERSION], [15:2:0])
AC_SUBST([ELPA_SO_VERSION], [15:3:0])
# AC_DEFINE_SUBST(NAME, VALUE, DESCRIPTION)
# -----------------------------------------
......@@ -40,15 +40,15 @@ AX_BUILD_DATE_EPOCH(ELPA_BUILDTIME)
# API Version
AC_DEFINE([EARLIEST_API_VERSION], [20170403], [Earliest supported ELPA API version])
print_earliest_api_version=20170403
AC_DEFINE_SUBST(CURRENT_API_VERSION, 20200417, "Current ELPA API version")
print_current_api_version=20200417
AC_DEFINE_SUBST(CURRENT_API_VERSION, 20210430, "Current ELPA API version")
print_current_api_version=20210430
# Autotune Version
AC_DEFINE([EARLIEST_AUTOTUNE_VERSION], [20171201], [Earliest ELPA API version, which supports autotuning])
print_earliest_autotune_version=20171201
AC_DEFINE([CURRENT_AUTOTUNE_VERSION], [20200417], [Current ELPA autotune version])
print_current_autotune_version=20200417
AC_DEFINE([CURRENT_AUTOTUNE_VERSION], [20200417], [Current ELPA autotune version])
AC_DEFINE_SUBST(CURRENT_AUTOTUNE_VERSION, 20200417, "Current ELPA autotune version")
AC_DEFINE([CURRENT_AUTOTUNE_VERSION], [20210430], [Current ELPA autotune version])
print_current_autotune_version=20210430
AC_DEFINE([CURRENT_AUTOTUNE_VERSION], [20210430], [Current ELPA autotune version])
AC_DEFINE_SUBST(CURRENT_AUTOTUNE_VERSION, 20210430, "Current ELPA autotune version")
AC_DEFINE_UNQUOTED([ELPA_BUILDTIME], [$ELPA_BUILDTIME], ["Time of build"])
AX_COMPARE_VERSION([$ELPA_BUILDTIME], [gt], [1623715200],[old_elpa_version=yes],[old_elpa_version=no])
......@@ -2303,13 +2303,13 @@ if test x"${ax_cv_have_avx512f_cpu_ext}" = x"yes" -a x"${need_avx512}" = x"no";
echo " "
fi
#echo " "
#echo "***********************************************************************"
#echo "* This is the first release candidate of ELPA 2020.11.001.rc1 *"
#echo "* There might be still some changes until the final release of *"
#echo "* ELPA 2020.11.001 *"
#echo "***********************************************************************"
#echo " "
echo " "
echo "***********************************************************************"
echo "* This is the first release candidate of ELPA 2021.05.001.rc1 *"
echo "* There might be still some changes until the final release of *"
echo "* ELPA 2021.05.001 *"
echo "***********************************************************************"
echo " "
if test x"$enable_kcomputer" = x"yes" ; then
echo " "
......
......@@ -19,7 +19,7 @@
%define with_openmp 0
Name: elpa
Version: 2020.11.001
Version: 2021.05.001.rc1
Release: 1
Summary: A massively parallel eigenvector solver
License: LGPL-3.0
......
......@@ -111,7 +111,7 @@
!>
!> ! We urge the user to always check the error code of all ELPA functions
!>
!> if (elpa_init(20200417) /= ELPA_OK) then
!> if (elpa_init(20210430) /= ELPA_OK) then
!> print *, "ELPA API version not supported"
!> stop
!> endif
......@@ -188,7 +188,7 @@
!>
!> /* We urge the user to always check the error code of all ELPA functions */
!>
!> if (elpa_init(20200417) != ELPA_OK) {
!> if (elpa_init(20210430) != ELPA_OK) {
!> fprintf(stderr, "Error: ELPA API version not supported");
!> exit(1);
!> }
......@@ -253,7 +253,7 @@
!> class(elpa_autotune_t), pointer :: tune_state
!> integer :: success
!>
!> if (elpa_init(20200417) /= ELPA_OK) then
!> if (elpa_init(20210430) /= ELPA_OK) then
!> print *, "ELPA API version not supported"
!> stop
!> endif
......
AC_PREREQ([2.69])
AC_INIT([elpa_test_project],[2020.11.001], elpa-library@mpcdf.mpg.de)
elpaversion="2020.11.001"
AC_INIT([elpa_test_project],[2021.05.001.rc1], elpa-library@mpcdf.mpg.de)
elpaversion="2021.05.001.rc1"
AC_CONFIG_SRCDIR([src/test_real.F90])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
AC_PREREQ([2.69])
AC_INIT([elpa_test_project],[2020.11.001], elpa-library@mpcdf.mpg.de)
elpaversion="2020.11.001"
AC_INIT([elpa_test_project],[2021.05.001.rc1], elpa-library@mpcdf.mpg.de)
elpaversion="2021.05.001.rc1"
AC_CONFIG_SRCDIR([src/test_real2.F90])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
AC_PREREQ([2.69])
AC_INIT([elpa_test_project],[2020.11.001], elpa-library@mpcdf.mpg.de)
elpaversion="2020.11.001"
AC_INIT([elpa_test_project],[2021.05.001.rc1], elpa-library@mpcdf.mpg.de)
elpaversion="2021.05.001.rc1"
AC_CONFIG_SRCDIR([src/test_real.c])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
AC_PREREQ([2.69])
AC_INIT([elpa_test_project],[2020.11.001], elpa-library@mpcdf.mpg.de)
elpaversion="2020.11.001"
AC_INIT([elpa_test_project],[2021.05.001.rc1], elpa-library@mpcdf.mpg.de)
elpaversion="2021.05.001.rc1"
AC_CONFIG_SRCDIR([src/test_real2.c])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment