Commit b88d8788 authored by Pavel Kus's avatar Pavel Kus
Browse files

error stop "..." removed

parent 6205cf76
......@@ -154,7 +154,8 @@ program test_interface
#endif
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -153,7 +153,8 @@ program test_interface
call timer%stop("set up matrix")
#endif
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -154,7 +154,8 @@ program test_interface
#endif
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -153,7 +153,8 @@ program test_interface
#endif
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -154,7 +154,8 @@ program test_interface
#endif
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -153,7 +153,8 @@ program test_interface
#endif
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -152,7 +152,8 @@ program test_interface
call timer%stop("set up matrix")
#endif
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -154,7 +154,8 @@ program test_interface
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -156,7 +156,8 @@ program test_interface
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -152,7 +152,8 @@ program test_interface
call timer%stop("set up matrix")
#endif
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -153,7 +153,8 @@ program test_interface
call timer%stop("set up matrix")
#endif
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -155,7 +155,8 @@ program test_interface
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -153,7 +153,8 @@ program test_interface
call timer%stop("set up matrix")
#endif
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -153,7 +153,8 @@ program test_interface
call timer%stop("set up matrix")
#endif
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -154,7 +154,8 @@ program test_interface
call timer%stop("set up matrix")
#endif
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -154,7 +154,8 @@ program test_interface
call timer%stop("set up matrix")
#endif
if (elpa_init(20170403) /= ELPA_OK) then
error stop "ELPA API version not supported"
print *, "ELPA API version not supported"
stop 1
endif
#ifdef HAVE_DETAILED_TIMINGS
call timer%start("prepare_elpa")
......
......@@ -83,7 +83,8 @@ module mod_setup_mpi
#ifdef WITH_MPI
if (nprocs <= 1) then
error stop "The test programs must be run with more than 1 task to ensure that usage with MPI is actually tested"
print *, "The test programs must be run with more than 1 task to ensure that usage with MPI is actually tested"
stop 1
endif
#endif
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment