Commit aa9c2719 authored by Andreas Marek's avatar Andreas Marek
Browse files

Change references from 2019.11.01 to 2020.05.001.rc1

parent cbb4e0c7
...@@ -10,9 +10,9 @@ The release ELPA 2018.11.001 was the last release, where the legacy API has been ...@@ -10,9 +10,9 @@ The release ELPA 2018.11.001 was the last release, where the legacy API has been
enabled by default (and can be disabled at build time). enabled by default (and can be disabled at build time).
With release ELPA 2019.05.001 the legacy API is disabled by default, however, With release ELPA 2019.05.001 the legacy API is disabled by default, however,
can be still switched on at build time. can be still switched on at build time.
With this release ELPA 2019.11.001, the legacy API will be deprecated and not supported anymore. With the release ELPA 2019.11.001, the legacy API will be deprecated and not supported anymore.
The release of ELPA 2020.05.001.rc1 does change the API and ABI compared to the release 2019.05.002, since The release of ELPA 2020.05.001.rc1 does change the API and ABI compared to the release 2019.11.001, since
the legacy API has been dropped. the legacy API has been dropped.
## How to install *ELPA* ## ## How to install *ELPA* ##
......
...@@ -2,7 +2,7 @@ ...@@ -2,7 +2,7 @@
## Current Release ## ## Current Release ##
The current release is ELPA 2019.11.001 The current supported API version The current release is ELPA 2020.05.001.rc1 The current supported API version
is 20190501. This release supports the earliest API version 20170403. is 20190501. This release supports the earliest API version 20170403.
The old, obsolete legacy API will be deprecated in the future ! The old, obsolete legacy API will be deprecated in the future !
...@@ -13,8 +13,7 @@ The release ELPA 2018.11.001 was the last release, where the legacy API has been ...@@ -13,8 +13,7 @@ The release ELPA 2018.11.001 was the last release, where the legacy API has been
enabled by default (and can be disabled at build time). enabled by default (and can be disabled at build time).
With release ELPA 2019.05.001 the legacy API is disabled by default, however, With release ELPA 2019.05.001 the legacy API is disabled by default, however,
can be still switched on at build time. can be still switched on at build time.
With the release ELPA 2019.11.001 the legacy API will be deprecated and With the release ELPA 2019.11.001 the legacy API has been deprecated and support has been droped.
not supported anymore.
[![Build [![Build
status](https://gitlab.mpcdf.mpg.de/elpa/elpa/badges/master/build.svg)](https://gitlab.mpcdf.mpg.de/elpa/elpa/commits/master) status](https://gitlab.mpcdf.mpg.de/elpa/elpa/badges/master/build.svg)](https://gitlab.mpcdf.mpg.de/elpa/elpa/commits/master)
......
...@@ -2,7 +2,7 @@ This file contains the release notes for the ELPA 2020.05.001.rc1 version ...@@ -2,7 +2,7 @@ This file contains the release notes for the ELPA 2020.05.001.rc1 version
What is new? What is new?
------------- -------------
For detailed information about changes since release ELPA 2019.11.001 please have a look at the Changelog file For detailed information about changes since release ELPA 2020.05.001.rc1 please have a look at the Changelog file
- improved GPU version of ELPA 2stage - improved GPU version of ELPA 2stage
- some new experimental features - some new experimental features
......
## Users guide for the *ELPA* library ## ## Users guide for the *ELPA* library ##
This document provides the guide for using the *ELPA* library with the new API (API version 20170403 or higher). This document provides the guide for using the *ELPA* library with the new API (API version 20170403 or higher).
Please do understand that this release deprecated the old, legacy interface API!
If you want to use the deprecated legacy API (we strongly recommend against this), please use the ELPA release If you want to use the deprecated legacy API (we strongly recommend against this), please use the ELPA release
2019.05.002 or older. 2019.05.002 or older.
...@@ -23,12 +22,6 @@ for each *ELPA* release is available. ...@@ -23,12 +22,6 @@ for each *ELPA* release is available.
With release 2017.05.001 of the *ELPA* library the interface has been rewritten substantially, in order to have a more generic With release 2017.05.001 of the *ELPA* library the interface has been rewritten substantially, in order to have a more generic
interface and to avoid future interface changes. interface and to avoid future interface changes.
The release ELPA 2018.11.001 was the last release, where the legacy API has been
enabled by default (and can be disabled at build time).
With release ELPA 2019.05.001 the legacy API is disabled by default, however,
can be still switched on at build time.
With the release ELPA 2019.11.001 the legacy API will has been deprecated and has been removed.
### Table of Contents: ### ### Table of Contents: ###
......
...@@ -1873,17 +1873,11 @@ fi ...@@ -1873,17 +1873,11 @@ fi
echo " " echo " "
echo "***********************************************************************" echo "***********************************************************************"
echo "* As announced, with this release candidate ELPA 2019.11.001, *" echo "* This is the first release candidate of ELPA 2020.05.001.rc1 *"
echo "* the legacy API has been finally removed ! *" echo "* There might be still some changes until the final release of *"
echo "* ELPA 2020.05.001 *"
echo "***********************************************************************" echo "***********************************************************************"
echo " " echo" "
#echo " "
#echo "***********************************************************************"
#echo "* This is a the first release candidate of ELPA 2019.11.001 *"
#echo "* There might be still some changes until the final release of *"
#echo "* ELPA 2019.11.001 *"
#echo "***********************************************************************"
#echo " "
if test x"$enable_kcomputer" = x"yes" ; then if test x"$enable_kcomputer" = x"yes" ; then
echo " " echo " "
......
...@@ -19,7 +19,7 @@ ...@@ -19,7 +19,7 @@
%define with_openmp 0 %define with_openmp 0
Name: elpa Name: elpa
Version: 2019.11.001 Version: 2020.05.001.rc1
Release: 1 Release: 1
Summary: A massively parallel eigenvector solver Summary: A massively parallel eigenvector solver
License: LGPL-3.0 License: LGPL-3.0
......
AC_PREREQ([2.69]) AC_PREREQ([2.69])
AC_INIT([elpa_test_project],[2019.11.001], elpa-library@rzg.mpg.de) AC_INIT([elpa_test_project],[2020.05.001.rc1], elpa-library@rzg.mpg.de)
elpaversion="2019.11.001" elpaversion="2020.05.001.rc1"
AC_CONFIG_SRCDIR([src/test_real.F90]) AC_CONFIG_SRCDIR([src/test_real.F90])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects]) AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
AC_PREREQ([2.69]) AC_PREREQ([2.69])
AC_INIT([elpa_test_project],[2019.11.001], elpa-library@rzg.mpg.de) AC_INIT([elpa_test_project],[2020.05.001.rc1], elpa-library@rzg.mpg.de)
elpaversion="2019.11.001" elpaversion="2020.05.001.rc1"
AC_CONFIG_SRCDIR([src/test_real2.F90]) AC_CONFIG_SRCDIR([src/test_real2.F90])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects]) AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
AC_PREREQ([2.69]) AC_PREREQ([2.69])
AC_INIT([elpa_test_project],[2019.11.001], elpa-library@rzg.mpg.de) AC_INIT([elpa_test_project],[2020.05.001.rc1], elpa-library@rzg.mpg.de)
elpaversion="2019.11.001" elpaversion="2020.05.001.rc1"
AC_CONFIG_SRCDIR([src/test_real.c]) AC_CONFIG_SRCDIR([src/test_real.c])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects]) AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
AC_PREREQ([2.69]) AC_PREREQ([2.69])
AC_INIT([elpa_test_project],[2019.11.001], elpa-library@rzg.mpg.de) AC_INIT([elpa_test_project],[2020.05.001.rc1], elpa-library@rzg.mpg.de)
elpaversion="2019.11.001" elpaversion="2020.05.001.rc1"
AC_CONFIG_SRCDIR([src/test_real2.c]) AC_CONFIG_SRCDIR([src/test_real2.c])
AM_INIT_AUTOMAKE([foreign -Wall subdir-objects]) AM_INIT_AUTOMAKE([foreign -Wall subdir-objects])
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment